Discussion:
Solaris/resource/jre/bin/java: cannot execute
(too old to reply)
VijayKandpal
2008-12-17 08:26:15 UTC
Permalink
Hi All,
While installing software TeamSite 6.7.1 sp1 on Solaris 10 86x machine iam getting following error message.
[b]./InstallerData/private.bin: /tmp/install.dir.5981/Solaris/resource/jre/bin/java: cannot execute[/b]

JDK installed is JDK1.5.
And path and classpath are set to /usr/bin/jdk/java1.5

Please Somebody let me know What steps I need to take to resolve this problem?

Thanks in advance
Vkandp
--
This message posted from opensolaris.org
Peter Tribble
2008-12-20 12:30:39 UTC
Permalink
Post by VijayKandpal
Hi All,
While installing software TeamSite 6.7.1 sp1 on Solaris 10 86x machine iam getting following error message.
[b]./InstallerData/private.bin: /tmp/install.dir.5981/Solaris/resource/jre/bin/java: cannot execute[/b]
JDK installed is JDK1.5.
And path and classpath are set to /usr/bin/jdk/java1.5
The TeamSite installer is trying to execute its own copy of java, so whichever
one you have in your path is irrelevant.

Setting classpath generally is a bad idea.

But my first question would be: does TeamSite run on Solaris x86, or
is it expecting
a sparc system?

Assuming that you've got something that will run on x86, then I would
look at the
file in the error message - what permissions does it have? Can you run
it manually?
(It's not clear whether the 'cannot execute' part of the error message
is generated by
the installer or by java; the installer might be hiding the real error.)
--
-Peter Tribble
http://www.petertribble.co.uk/ - http://ptribble.blogspot.com/
Loading...